El algoritmo más antiguo de la historia

Publicado el 12-11-2010

No sé si el título de este post es del todo cierto pero si no es así poco le falta. Recuerdo que en la Universidad nos hablaron de este algoritmo, que se remonta a la época de los griegos y trata de dividir dos números utilizando tan sólo restas.

 

Brevemente explicado el algoritmo dice que para dividir A entre B basta con restar "B" a sucesivamente a A sin pasar de 0. El número de veces que se haya realizado la resta es el resultado de la división. El número que tenemos cuando paramos de restar "B" porqué nos pasaríamos de 0 es el residuo.

 

En pseudocódigo sería:

var a,b,resultado: enteros
Leer(a)Leer(b)
resultado = 0
Mientras(a>=b)
a = a - b;
resultado = resultado + 1;
FinMientras
Escribir(resultado)
Escribir(a)

Y en php:

a=$_POST["a"];
b=$_POST["b"];
resultado=0;
while(a>=b){
a=a-b;
resultado++;
}
echo resultado;
echo a;
Categorías: Algoritmos

Comparte este artículo

Comenta este artículo

Web Project & Online Marketing Proogresa S.L. © 2020 | Condiciones Legales | Política de Privacidad | Política de Cookies | Mapa del Sitio | Compliance


¡Seguimos trabajando! Nos hemos adaptado a las medidas excepcionales que estamos viviendo y seguimos trabajando al 100% de nuestras capacidades. Más info.